Error 1 Reference.svcmap: Could not load file or assembly xxxxxxx etc

I recently got my new Dell XPS 15 laptop with Windows 8 64bit on it. After installing all my programming software I ran into an interesting compiler error in Visual Studio 2010:

Error 1 Reference.svcmap: Could not load file or assembly 'antlr.runtime, Version=2.7.6.2, Culture=neutral, PublicKeyToken=1790ba318ebc5d56' or one of its dependencies. The system cannot find the file specified. App_WebReferences/TranslatorService/


I Googled a bit, but there were no usable solutions out there, so I investigated a bit more myself. I noticed the error mentioned the Reference.svcmap, and the only service reference I had in my project was to the Bing translator service. I opened the configuration screen and noticed the red highlighted checkbox you can see in the screenshot below: 'Reuse types in referenced assemblies'. I didn't really know what the setting did, but I tried to uncheck it, hit OK and guess what... the project compiled and ran just fine!

After reading up some documentation on the setting, I actually got more confused. If you ask me, this error should have occurred on my Windows 7 + Visual Studio 2010 setup just aswell as on my Windows 8 + Visual Studio 2010 setup. Only the latter gave me the error though...

I hope this might help some of you out there.

 

Comments (2) -

Roger
Roger
4/18/2013 10:17:56 PM #

You are a freaking saint, man.

I was tearing my hair out over this exact error, only I had several web services, and the error would randomly hop between them. This is exactly what I needed! Turning that checkbox off on all of them took care of it.

You rock!

Royce Nicolette
Royce Nicolette
5/23/2013 12:23:09 PM #

There are surely a couple much more details to take into consideration, but thanks for sharing this info.

Add comment

  Country flag

biuquote
  • Comment
  • Preview
Loading

About the author

Check my LinkedIn profile for more info:

 

Month List

Page List